INLONESTAR
DXSOFTWORN

VSBACKUP 4.0.944.2021



VSBackup v4.0.944.2021

CONTENTS
o =T o= To [ U= A o =L PP PPPPRURRPO 2
1] oY= = e o o 2
BACKUP ettt h e bttt et et bttt e a bttt eh e e bt e bt e a b e ehe e eh e ekt e a b e eabeebt e beeabeeabesatenbeas 2
VLIEWING BACKUPS c.etiiiiieitie ittt ettt ettt sttt e st e s a e e s a bt e bt e e bt e e abeesabaeeabeesabeesabeebeeesbeenbeesaseesabaesaseennee 5
Y= o o =TT TP ST U TP P PO PO UPOUSORTROPRPRRTRPN 8
BACKUD LOCATION Lttt ettt h e s bt ettt e s at e sbe et e e a b e ehe e bt eab e e st e ebe e beenbeeabesbeenaeeeas 9
Backup NamIing OPTLONS ..ottt ettt ettt e s bt e s beesat e e sabeesaeesnbeesseesabeesseesane 10
Zip (COMPIESS) BACKUP .oeiiiiiitictieiee ettt ettt ettt ettt e b bt e st eae e st e st et et e ss e besbesbeebesaeenneneenean 11
[0 (o o= PP PP P PO P PP PP PPPPPPPPPPPPPPPPPPPPPIRY 12
(0] o X oo Y P 15
BACKUPD EVENTS .ottt ettt st et s e e s at e e s bt e e bt e e bt e e abe e sa ke e e abeesb b e e sabeenbeeassbesabeesabeesabeesaseenateas 15
DAt@ FLLE BaACKUP . cuiiiiiiiiiieee ettt e rb e ettt e st e st e e sat e e sabeesbee s bte e bt e sabeeenbeesabeesaneenaee 16
GENEINAL ST INES i et s st 18
= T= T 1o - T of 19
REPOINEAING IS SURS e vt ittt ittt ettt teeesneeeeesoeenesesssesssssssssssssssnssnsnsnsnnnns 19
RELEase NOTES . ittt ittt annsnsnsnnnsnnnnnas 20
1|Page Copyright © 2020-2021 Lonestar Softworx

LONESTAR




VSBackup v4.0.944.2021

VSBackup is a Visual Studio extension for backing up and restoring a solution without
having to leave Visual Studio. VSBackup is a very useful extension if you are not
using any version control or if you are in the prototyping stage. This is not a
substitute for source control. Take care of your code files. Only full backups are
performed.

PREREQUISITES

VSBackup uses Robocopy for the backup process. Please make sure that Robocopy.exe is
located at the following location, ‘C:\Windows\System32’ before the backup operation.
As of now, VSBackup has only been tested with Visual Studio 2017.

OPERATION

BACKUP

To start a backup, either load an existing solution or create one. You will find the commands for VSBackup in the
VSBackup menu on the Tools menu.
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Python »
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Spy++
External Tools...

Command Line »
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Custon ~e...

There are two ways to start the backup process. The first way is to right-click on
the solution and then click the VS Backup - Start Backup menu item on the context-
menu.
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M Properties Alt+Enter

.= VSBackup - Start Backup

The other way is to click the Start Backup menu command located in the VSBackup Tools
menu. If this is the first backup for the solution, the settings form will be
displayed. Either change the location of the backup or accept the default backup
location. See the Settings section for instructions. Click the OK button.
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Once the backup is complete, either success or fail, a message box will be displayed.

VIEWING BACKUPS

To view a list of backups for the solution, click View -> Other Windows - VSBackups -
Backups.
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A window with the backups associated with the solution will appear.

Backups v a1 X ?
........................ - =
QHardDeletes €) Soft Delete " Restore 4 Refresh = §
Name Backup Date/Time
(2] ConsoleApp1_2021_7_24_0_40_59 07/24/2021 12:40:59 AM

Each backup will have an image next to image denoting the type of backup.

Entries that have this image, < will show that the backup was zipped. This image,

“J Will show that the folder was backed up without compression.

To sort backups, click the column you want to sort by, and it will sort by ascending
or descending order.

The Backups tool window has four toolbar items.

Hard Delete Deletes the backup from the list as well as the backup
location.
Soft Delete Deletes the backup from the backup list only.
Restore Restores a backup to a specified location.
Refresh Refreshes the backup 1list.
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SETTINGS

To change the settings, click the Settings menu command located in the Tools menu.

Project Build Debug Test Analyze Extensions Window Help

Get Tools and Features...
Code Compare »

VSBackup »

Start Backup

«:

Connect to Database... Restore

Connect to Server... 197 Settings

<«
m w
)

SQL Server » ﬁ' Report A Problem

Datalake b | @ Leave Feedback
Enter License Key...
[1 Code Snippets Manager... Ctrl+K, Ctrl+B

About VSBackup

Choose Toolbox Items...

NuGet Package Manager »
Python »
Create GUID

Error Lookup

Spy++
External Tools...

Command Line »

Import and Export Settings...

Custonr ~e...

The following form will be displayed with several options.
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{07 Settings =

- = Backup

[

Backup Location:  ¢:\Users\met\Documents MyBackUpData

MHaming Options
(® L=e Solution Name i) Prompt for name on each backup

i) U=e custom name

E Compression
[ ] Zip Badkup?

Password protect Fip file? -

Oy Zip backup if the salution ls areater tha 1 K

© ok| [§8 Cancdl |

BACKUP LOCATION

To change the location where the backups for the solution will be stored, either type

the location into the text area labeled Backup Location or click the = button
located to the right of the text area.
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{07 Settings =

- = Backup

Backup Location:  ¢:\sers et \Documents MyBackUpData =

MHaming Options
(® L=e Solution Name i) Prompt for name on each backup

i) U=e custom name

E Compression
[ ] Zip Badkup?

=

aseword protect Zip file? -

Cnly Zip backup it

e stlution |s greater tha

BACKUP NAMING OPTIONS

There are three options for naming the backup:
Use Solution Name The backup will have the same name as the solution.
Prompt for name on each backup Displays a prompt for the name of the backup.

Use Custom Name The backup will have the name of whatever is entered
into the text box.
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1) Settings X

- = Backup
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MHaming Options
(® L=ze Solution Name i) Prompt for name on each backup

i) Use custom name

@_ Compression
|1 Zip Backup?
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ZIP (COMPRESS) BACKUP

To Zip (compress) the backup, enable the Zip Backup option.
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o7 Settings =

- m Backup

)

Backup Location: | C:\sers'pmet\Documents MyBaddpData

MHaming Options
(® L=e Solution Name i) Prompt for name on each backup

i) Use custom name

& Compression

|| Zip Badkup?

@ Ok 3% Cancel

To password protect the Zip file, enable the Password Protect Zip File? option.
Password must be at least 8 characters in length. To view what you have typed, click

=
the ' button. To hide what you typed, click the button.

To only back up the solution directory if the folder size is greater than a certain
amount, click the Only Zip backup if the solution is greater than option and enter an
amount.

To save the settings, click the OK button. To discard any changes or just to exit the
form, click the Cancel button.

A form will appear listing the selected and entered options. You can turn this form
off and on by going to Tools -> Options > VSBackup - General Settings and checking
or un-checking the Show Backup Options Summary.

RESTORE
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To restore a backup, select the backup from the Backups tool window.

sdnyoeg

:{€3 Hard Delete € Soft Delete M ¥ Refresh _

Backup Date/Time

Name
07/24/2021 12:40:59 AM

[ ConsoleApp1_2021_7_24 0_40_59

Click the button labeled Restore on the Backups tool window or click the Restore

button in the Tools menu.
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Project Build Debug

Test  Analyze Extensions Window Help

«:

«:

Get Tools and Features...
Code Compare
VSBackup

Connect to Database...

Connect to Server...
SQL Server

Data Lake

Code Snippets Manager...

Choose Toolbox Items...

NuGet Package Manager
Python
Create GUID

Error Lookup

Spy++
External Tools...

Command Line

Import and Export Settings...

Custon ~e...

soleApp1 v| ii| ; ¥ ff

Start Backup

Restore
197 Settings

Sk ; Report A Problem
Leave Feedback

Enter License Key...
Ctrl+K, Ctrl+B

About VSBackup

When the dialog box appears, select the location where you want to restore the
solution to. To make a new location, click the Make New Folder button. Click the OK
button.
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Browse For Folder -

Select the directory that you want to restore the backup to.

= This PC

> ZJ 3D Objects

> I Desktop

¥ Documents

» ; Downloads

¥ J‘J Music

» [&=] Pictures

5 g ScanSnap Folder
> B Videos

5 22 Windows ()

» == Shared Music {\\ — W Public) (23]

| Make New Folder | ok || canel

Once the restore process has completed, either success or failure, a message box will
be displayed.

OPTIONS

BACKUP EVENTS
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Options ?
Search Options (Ctrl+E) ol ~ Files
b Live Unit Testing = After File is Added False
b Nodejs Tools After File is Removed False
b NuGet Package Manager After File is Renamed True
b Python v Projects |
I Service Fabric Tools After Directory is Added False »
B Snapshot Debugger After Directory is Removed False
I S0L Server Tools After Directory is Renamed False
[ Test After Project is Added False
[: Test Adapter for Google Test Project is Removed False
[ Text Templating v Solution
4 VSBackup After Solution Closes False
1 Backup Events ] After Solution Opens False
Data File Backup
General Settings
I Web Forms Designer After Directory is Added
b Web Live Preview (Preview) Perform a backup after a directory is added to a project.
I Web Performance Test Tools »

o) o

You can now back up your solution when an event fires in Visual Studio. Select either
True or False from the drop down for each option and then click the OK button to save

your changes.

DATA FILE BACKUP

To back up the data file, go to Tools > Options -> VSBackup and select the Data File

Backup
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Options ? *

Search Options (Ctrl+E) ol Current Backup Location: Childsers, \Documentst MyBackupDatatl onestarbe

Live Unit Testing " Backups to Keep: 1 =]
MNede,js Tools =

MNuGet Package Manager Sackup Freuttey
Python Last Backup Date: 08/10/2021
Service Fabric Tools

Snapshot Debugger

SOL Server Tools
Test Backups

Test Adapter for Google Test ic 2021 8 10 12 25 20,data

. Restare
Text Templating

V5Backup
Backup Events
| Data File Backup |
General Settings
I Web Forms Designer
I Web Live Preview (Preview)
I Web Performance Test Tools bt

h = T T T T T

To change the location, click the link labeled Current Backup Location and then
select the preferred backup location.

To keep to only a of certain of backups, change the Backups to Keep value by clicking
the down or up arrow button.

To change when the data file will be backed up, select an option from the Backup
Frequency drop-down. The Daily, Weekly, or Monthly options can only be chosen if a
manual backup has been performed first. These backups will occur when the solution
closes.

Manual The backup will not be done automatically and will be performed
every time when the button is clicked.

Daily The backup will occur every day after the last backup date.

Weekly The backup will occur every 7 days after the last backup.

Monthly The backup will occur every 30 days after the last backup date.
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To restore a data file backup, select the backup you want to restore from the list
labeled Backups. Then click the Restore button. You must close then open a solution
to reload the backups for that solution.

GENERAL SETTINGS

To turn on or to turn off the backup settings summary form, check or un-check the
Show Backup Options Summary checkbox.

Options ? *

Search Options (Ctrl+E) o 17 General Settings

Live Unit Testing ~
Mode,js Tools

MuGet Package Manager

Python

Service Fabric Tools

[ | show Backup Options Summary?

Automatic Backup Interval:

Snapshot Debugger
50L Server Tools
Test
Test Adapter for Google Test
Text Templating Convert Data File
V5Backup

Backup Events

Data File Backup

General Settings |
I Web Forms Designer

h = T T T T T

I Web Live Preview (Preview)
- Web Performance Test Tools b

To initiate automatic backups at a specified interval which are in minutes, select
the value from the drop down labeled Automatic Backup Interval. Selecting © will turn
of the automatic backups.

Click the OK button to save.
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Starting with Version 2.x, if you are upgrading from Version 1.x, the data file must
be converted. This option will only be enabled if you have to convert the data file.

FEEDBACK

To leave a suggestion or feedback on how we can improve VSBackup or to rate VSBackup,
click the Leave Feedback menu item.

Project Build Debug Test Analyze @ Tools

Get Tools and Features...

Extensions Window Help
soleAppl ~ | i | @ - o

Code Compare >

VSBackup 3

Start Backup
Restore
Settings

«:

-«
m «o

Connect to Database...

Connect to Server...

B @l

SQL Server »
Data Lake » | « LeaveFeedback

Report A Problem

Enter License Key...
[l Code Snippets Manager... Ctrl+K, Ctrl+B

About VSBackup

Choose Toolbox ltems...

NuGet Package Manager »
Python >
Create GUID

Error Lookup

Spy++

External Tools...

Command Line »

Import and Export Settings...

Customr e...

REPORTING ISSUES
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To report an issue, click the Report a Problem menu command. The Report a Problem form will also be displayed if
any catastrophic issue arises. You will have an opportunity to review it before sending it.

Project Build Debug Test Analyze

Get Tools and Features...

Extensions Window Help
soleApp1v|ﬁ|=§§§h'-ﬁ

Code Compare »

VSBackup »

Start Backup
Restore
Settings

-«
F Ll

«:
m o
"
| &

Connect to Database...

Connect to Server...

SQL Server » Report A Problem

JH e

Daallake > Leave Feedback
Enter License Key...
[l Code Snippets Manager... Ctrl+K, Ctrl+B

About VSBackup

Choose Toolbox Items...

NuGet Package Manager »
Python »
Create GUID

Error Lookup

Spy++

External Tools...

Command Line »
Import and Export Settings...

Customr e...

RELEASE NOTES

20|Page Copyright © 2020-2021 Lonestar Softworx

LONESTAR




VSBackup v4.0.944.2021

> 4.0.944.2021 - 09/13/2021

o When a backup is right clicked, a context menu is displayed with commands to
either perform a Hard or Soft Delete or to Restore a backup.

o When the Backups area is right-clicked, a context-menu will display with the
Refresh command.

o Re-arranged and grouped menu items in the VSBackup Tools menu.
o When certain events happen in Visual Studio, a backup is performed.
» 3.1.550.2021 - 06/30/2021

o [FIXED]: Going to Tools --> Options --> VSBackup causes Visual Studio to
Crash.

o [FIXED]: The backup location is not saved.
o [FIXED]: The License Key activation fails.

» 3.0.540.2021 - 05/07/2021

o Added the ability to leave feedback, a suggestion, or give the extension
a rating.

o Backing up the data file manually or on a schedule has been added. Also,
the ability to restore a data file backup has been added.

» 2.2.352.2021 - 04/02/2021

@)

[FIXED]: The name of the backup is the solution directory name instead of
the solution name.

> 2.1.342.2021 - 04/01/2021
o Various UI modifications.
> 2.0.340.2021 - 03/26/2021

o Various UI enchantments and modifications.
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o If a backup is selected to be restored and if it does not exist, the option
to remove it from the backup list has been added.

o The ability to Zip (compress) a solution has been added. A password for the Zip
file can be set. Also, an option to Zip the solution when it is greater than a

specified amount has been added.

o Sorting can now be performed on the Backup Date/Time and Name columns in
the Backups list.

o An icon will appear next to the backup denoting the type of backup,
directory or Zip.

o There is 30-day trial period of the extension. When the trial period ends,
backups can no longer be performed.

o The format for the data file has changed.
» 1.5.102.2021 - 01/21/2021

[FIXED]: When the extension failed to load in Visual Studio 2017 due to an
assembly reference issue.

@)

» 1.4.101.2021 - 01/12/2021

@]

[FIXED]: When opening a solution in Visual Studio 2019 using the Open Recents
dialog, the Visual Studio events would not fire causing the backup settings
and backups not to load. Nor could a backup profile be created.

> 1.3.100.2021 - 01/06/2021

o Added logging

» 1.2.99.2021 - 01/06/2021

o Upgraded for Visual Studio 2019
> 1.1.93.2021 - 01/01/2021
o [FIXED]: When submitting a Problem Report, leaving a required field empty
and then filling it in would result in a loop when re-submitting the Problem
Report
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> 1.87.2020 - 12/24/2020

o Initial Release
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