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VSBackup is a Visual Studio extension for backing up and restoring a solution without 
having to leave Visual Studio. VSBackup is a very useful extension if you are not 
using any version control or if you are in the prototyping stage. This is not a 
substitute for source control. Take care of your code files. Only full backups are 
performed. 

 

PREREQUISITES  

 

There are no prerequisites. 

 

OPERATION 

BACKUP 

 

To start a backup, either load an existing solution or create one.  You will find the commands for VSBackup in the 
VSBackup menu on the Tools menu.  
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 There are two ways to start the backup process. The first way is to right-click on 
the solution and then click the VS Backup – Start Backup menu item on the context-
menu. 
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The other way is to click the Start Backup menu command located in the VSBackup Tools 
menu.  
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If this is the first backup for the solution, the settings form will be displayed. 
Either change the location of the backup or accept the default backup location. See 
the Settings section for instructions. Click the OK button. 

Once the backup is complete, either success or fail, a message box will be displayed. 

EXCLUDING ITEMS 

 

To exclude an item, right-click on the item and then click the VSBackups – Exclude menu item. 
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To include the item, right-click on the item and click the VSBackups – Include menu item. 
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VIEWING BACKUPS 

 

To view a list of backups for the solution, click View -> Other Windows – VSBackups – 
Backups. 
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A window with the backups associated with the solution will appear.  

 

 

Each backup will have an image next to image denoting the type of backup. 

 Entries that have this image,  will show that the backup was zipped. This image, 

 will show that the folder was backed up without compression. 

To sort backups, click the column you want to sort by, and it will sort by ascending 
or descending order. 

The Backups tool window has six toolbar items: 

Hard Delete  Deletes the backup from the list as well as the backup location. 

Soft Delete  Deletes the backup from the backup list only. 

Restore  Restores a backup to a specified location. 

Refresh  Refreshes the backup list. 

From/To Allows you to filter the backups by date. To revert to the       
complete list of backups, click the Refresh button. 

BACKUP NOTE 

 

You can add a note or edit an existing note to a backup.  
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Right-Click on the backup you want to enter a note for. Click the Edit Note menu 
item. 

 

 

Enter the text of the note. To save the note, click the Save button. To cancel the save, click the Cancel button. 

 

Once the note is saved, there will be a Note icon next to the backup. 
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To delete the note, click the Delete Note button. 

 

RESTORE 

 

To restore a backup, select the backup from the Backups tool window. Either select 
Restore from the toolbar, right-click on the selected backup then click Restore from 
the menu or click Restore from the VSBackup menu. 
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Once the restore process has completed, either with a success or failure, a message 
box will be displayed. 
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SETTINGS 

 

To change the backup and restore settings, click the Settings menu command located in 
the Tools menu. 

 

 

The following form will be displayed with two tabs. 
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BACKUP 

LOCATION 

There are three options for setting up the location for the backup: 

Use Default Location The backup will always be stored at this 
location.  

Prompt for location on each backup Displays a prompt for the location of the 
backup. 
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Use this location Allows you to either type in a location, select a location by 

clicking the folder icon   , or selecting a previously saved 

restore location by clicking the drop-down arrow,  .  

 

NAMING 

There are three options for naming the backup: 

Use Solution Name   The backup will have the same name as the solution. 

Prompt for name on each backup Displays a prompt for the name of the backup. 

Use Custom Name The backup will have the name of whatever is entered 
into the text box.  
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BACKUP LIMIT 

There are three options when limiting the number of backups: 

No Limit     All backups will be kept. 

Keep only the last # days of backups Any backups older than the specified days will be deleted. 

Keep only # backup(s) The number of specified backups will be kept.  
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ZIP (COMPRESS) 

 

To Zip (compress) the backup, enable the Zip Backup option. 
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To password protect the Zip file, enable the Password Protect Zip File? option. 
Password must be at least 8 characters in length. To view what you have typed, click 

the  button. To hide what you typed, click the button again. 
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To only back up the solution directory if the folder size is greater than a certain 
amount, click the Only Zip backup if the solution is greater than option and enter an 
amount.  
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To save the settings, click the OK button. To discard any changes or just to exit the 
form, click the Cancel button.  

A form will appear listing the selected and entered options. You can turn this form 
off and on by going to Tools  Options  VSBackup  General Settings and checking 
or un-checking the Show Backup Options Summary.  

EXCLUSIONS 

To exclude any file or folder in the solution from being backed up, select this setting. When clicked, the file and 
directories in the solution will be presented.  
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Un-Check the item that needs to be excluded. Un-check the folder to exclude all the 
items in that folder.  

 

To include the item in the backup, check the box again next to the item. 
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To narrow the list of items, enter the text in the Filter text box. 

 

 

Click the  button and the items that match the filter will appear in the list. 
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To remove the filter and start over, click the  button. 
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To collapse and hide all items in the list, click the   button. 
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To expand and see the list, click the   button.  
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To un-check or check all items, click the  button. 
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To refresh the list, click the   button

 

 

RESTORE 

LOCATION 

 

There are three options for setting up the restore location for the backup: 

Use Default Location The backup will always be restored to this 
location. 

Prompt for location on each restore Displays a prompt for the location of the 
restore. 

Use this location Allows you to either type in a location, 
select a location by clicking the folder icon

  , or selecting a previously saved restore 

location by clicking the drop-down arrow,  .  
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OPTIONS 

 

To access the options for VSBackup, you can click Tools  Options and scroll down to VSBackup or you can select 
the click the Options menu item on the VSBackup menu. 
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BACKUP EVENTS 
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You can now back up your solution when an event fires in Visual Studio. Select either 
True or False from the drop down for each option and then click the OK button to save 
your changes. 

DATA FILE BACKUP 

 

To back up the data file, go to Tools  Options  VSBackup and select the Data File 
Backup  



VSBackup v7.0.1054.2022 

34 | P a g e    C o p y r i g h t  ©  2 0 2 0 - 2 0 2 2  L o n e s t a r  S o f t w o r x  

   

 

34 

 

To change the location, click the link labeled Current Backup Location and then 
select the preferred backup location. 

To keep to only a of certain of backups, change the Backups to Keep value by clicking 
the down or up arrow button.  

To change when the data file will be backed up, select an option from the Backup 
Frequency drop-down. The Daily, Weekly, or Monthly options can only be chosen if a 
manual backup has been performed first. These backups will occur when the solution 
closes. 

Manual  The backup will not be done automatically and will be performed 
every time when the button is clicked. 

Daily    The backup will occur every day after the last backup date.         

Weekly   The backup will occur every 7 days after the last backup. 

Monthly  The backup will occur every 30 days after the last backup date. 
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To restore a data file backup, select the backup you want to restore from the list 
labeled Backups. Then click the Restore button. You must close then open a solution 
to reload the backups for that solution. 

 

 

GENERAL SETTINGS 

 

To turn on or to turn off the backup settings summary form, check or un-check the 
Show Backup Options Summary checkbox. 

 

 

To initiate automatic backups at a specified interval which are in minutes, select 
the value from the drop down labeled Automatic Backup Interval. Selecting 0 will turn 
of the automatic backups. 

Click the OK button to save. 
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Starting with Version 2.x, if you are upgrading from Version 1.x, the data file must 
be converted. This option will only be enabled if you have to convert the data file. 

FEEDBACK  

 

To leave a suggestion or feedback on how we can improve VSBackup or to rate VSBackup, 
click the Leave Feedback menu item. 

 

REPORTING ISSUES 

 

To report an issue, click the Report a Problem menu command. The Report a Problem 
form will also be displayed if any catastrophic issue arises. You will have an 
opportunity to review it before sending it. 
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RELEASE NOTES 

  

 7.0.1054.2022 - 12/03/2022 
 

o If the location for the data file backup is too long, the remaining 
characters will be represented by '...' 
 

o Added the ability to exclude files and directories from the backup 
process. 
 

o An item can be excluded from or included in a backup by selecting a menu 
command on the context-menu for that item. 

 
o Added the ability to limit the number of backups to a specified amount 

or a specified number of days. 
 

o If a backup has a note, an icon will be displayed in the backups 
listing. 



VSBackup v7.0.1054.2022 

38 | P a g e    C o p y r i g h t  ©  2 0 2 0 - 2 0 2 2  L o n e s t a r  S o f t w o r x  

   

 

38 

 
o Internal code enhancements. 

 
o Added menu items for social media sites. 

 
 

 6.7.1005.2022 - 03/28/2022 
 

o [FIXED]: Installation targets. 
 

Changed the URL for the VSBackup page on the product registration form. 

 
 6.6.1004.2022 - 03/21/2022 

 
o [FIXED]: submitting a Problem Report and Feedback. 

 
 6.5.1003.2022 - 03/21/2022 

 
o Modified the purchase link. 

 
 6.4.1002.2022 - 02/08/2022 

 
o Fixed issues with submitting a Problem Report and Feedback. 

 
 6.3.999.2022 - 01/24/2022 

 
o Fixed an issue with the Restore location settings not being set 

correctly. 
 

o Fixed an issue with the Restore process not working correctly. 
 

 6.2.996.2022 - 01/20/2022 
 

o Fixed an issue with the backup location items not being set correctly.  
 

 6.1.995.2022 - 01/18/2022 
 

o Fixed an issue that would cause an error message to be displayed when 
clicking the Report, a Problem menu item. 

 
 6.0.994.2022 - 01/17/2022 

 
o Added the ability to add or delete a note on a backup. 
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o Added the ability to filter the backups list by a date range. 
 

o Added Options command to the VSBackup to take the user directly to the 
Options page for VSBackup. 

 
o Added Help command to take the user to the documentation web page for 

VSBackup. 
 

o Enclosed the Backup operation in a thread. 
 

o Added Backup location options. 
 

o Added Restore location options. 
 

o Redesigned the Settings form. 
 

 5.1.980.2021 - 11/23/2021 
 

o Fixed an issue with the Install Target being incorrect in the VSIX   
manifest file. 
 

 5.0.979.2021 - 11/22/2021 
 

o Converted to Visual Studio 2022. 
 

o Minor bug fixes. 
 

o Removed data conversion process. 
 

 4.0.944.2021 - 09/13/2021 
 

o When a backup is right clicked, a context menu is displayed with 
commands to either perform a Hard or Soft Delete or to Restore a backup. 

. 
 

o When the Backups area is right-clicked, a context-menu will display with 
the Refresh command. 

 
 

o Re-arranged and grouped menu items in the VSBackup Tools menu. 
 

o When certain events happen in Visual Studio, a backup is performed. 
 

 3.1.550.2021 – 06/30/2021 
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o [FIXED]: Going to Tools --> Options --> VSBackup causes Visual Studio to 
Crash. 
 

o [FIXED]: The backup location is not saved. 
 

o [FIXED]: The License Key activation fails. 
 

 3.0.540.2021 – 05/07/2021 
 

o Added the ability to leave feedback, a suggestion, or give the extension 
a rating. 
 

o Backing up the data file manually or on a schedule has been added. Also, 
the ability to restore a data file backup has been added. 

 
 2.2.352.2021 – 04/02/2021 

 
o [FIXED]: The name of the backup is the solution directory name instead 

of the solution name. 
 

 2.1.342.2021 – 04/01/2021 
 

o Various UI modifications. 
 

 2.0.340.2021  – 03/26/2021 
 

o Various UI enchantments and modifications. 
 
o If a backup is selected to be restored and if it does not exist, the 

option to remove it from the backup list has been added. 
 
o The ability to Zip (compress) a solution has been added. A password for the 

Zip file can be set. Also, an option to Zip the solution when it is greater 
than a specified amount has been added. 

 
o Sorting can now be performed on the Backup Date/Time and Name columns in 

the Backups list. 
 
o An icon will appear next to the backup denoting the type of backup, 

directory, or Zip. 
 
o There is 30-day trial period of the extension. When the trial period 

ends, backups can no longer be performed. 
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o The format for the data file has changed.  

 
 1.5.102.2021  – 01/21/2021   

 
o [FIXED]: When the extension failed to load in Visual Studio 2017 due to 

an assembly reference issue. 
 

 1.4.101.2021 – 01/12/2021 
  

o [FIXED]: When opening a solution in Visual Studio 2019 using the Open 
Recants dialog, the Visual Studio events would not fire causing the 
backup settings and backups not to load. Nor could a backup profile be 
created. 

 
 1.3.100.2021 – 01/06/2021  

 
o Added logging 

 
 1.2.99.2021 – 01/06/2021 

 
o Upgraded for Visual Studio 2019 

 
 1.1.93.2021  –   01/01/2021  

 
o [FIXED]: When submitting a Problem Report, leaving a required field 

empty and then filling it in would result in a loop when re-submitting 
the Problem Report 
 

 1.87.2020  – 12/24/2020  
 

o Initial Release 
 


